Translating Offline

From OTPedia
Jump to: navigation, search

Contents

Why would you want to translate offline?

There can be many reasons for offline translations, for example:

If any of this is true for you, offline translation might be an option for you.

What is offline translation?

Offline translation is translating a transcript outside of the online Amara interface. It is still done on your computer, but without the need to be constantly connected to the internet. This involves downloading the original transcript to your computer, doing the translation, then uploading the result back into Amara. Naturally, you must be connected for the downloading and uploading part.

Downloading the transcript from Amara

On a talk’s Video page, select the language you’d like to download from the left sidebar Use the Download drop-down menu to choose the file format. More information can be found in the Amara quick guide. [1].

While there are many formats there, the best probably is to choose the SubRip (.srt) format, which is offered by default. It is the simplest out of all formatting, and contains the timing data and the text in separate lines, thus also easier to read and handle.

Once you have clicked on the desired language, the subtitles in a text file with .srt extension (if you chose SubRip) will be downloaded by your web browser.

Handling the downloaded .srt file

You can open the .srt file by any text editor software on you computer, including Notepad or Word if you are running Windows. The file is structured in blocks as follows:

1
00:00:00,000 --> 00:00:02,000
Humans in the developed world

2
00:00:02,000 --> 00:00:05,000
spend more than 90 percent of their lives indoors,

During translation, all you have to do is: replace the original text in the "Text of subtitle line" with your translated line, and leave everything else intact.

1
00:00:00,000 --> 00:00:02,000
Az emberek a fejlett világban

2
00:00:02,000 --> 00:00:05,000
életük több mint 90%-át beltérben töltik,

Upon opening the file, your text editor might ask you a couple of questions, to know how to read the file properly:

It is important that you do not change the timing, the subtitle number or the blank lines in any way, otherwise you won't be able to upload the result to Amara.

Obviously you will need to save your file after the translation, as a best practice always give a different name and a version number to each saved state. When you save your work, check the file extension, as some text editor saves everything with the .txt extension. If that is the case, correct it to .srt.

Uploading the translated file to Amara

Once you are done with the translation, find the Task you’re assigned to (click “Your tasks” on the left sidebar), hover over ‘Perform Task’ and click “Upload draft”.

You can check in the Revision history if your import was successful. Sometimes, special characters appear distorted upon which you may have change the encoding in the file you would like to upload, and try another upload.

Setting up your offline translation environment

Amara offers one great convenience for translating: you can see the original English text and your translated text at the same time, one under the other. To efficiently translate in an offline environment you need some similar setup. One method close to that is to keep your original and your translated file in two separate windows lined up next to each other, while your scrolling is synchronized among them.

Below are two tips to create such an environment.

Using Microsoft Word

As most people are using Windows based computers, where Microsoft Word is available, here are some simple tips for them.

  1. Download the .srt file as instructed above.
    Side by side in Word
  2. Make a copy of the downloaded file, with a different name (e.g. change the ENG part to your translating language, like HUN). The original will be your source file that you leave intact, the copy will be your working file.
  3. Start up Microsoft Word, and open both the source and your work file from the File -> Open menu. A File conversion panel might ask you to select the file encoding. Choose Other encoding then from the list Unicode (UTF-8) and click OK.
  4. Once you have both file open, select Window -> Compare side by side with... Two window panels will appear next to each other. The active window during your menu selection will be placed on the left side of the screen. Scrolling between the windows will be synchronized. If the two windows are not alogned for some reason, click on the Reset window position button in the just appeared menu box.
  5. Now you can do your translation by keeping e.g. in the left window the original file, and writing your translation into the other file in the right window.
  6. When you are done, save the result. When Word asks you for the format, always choose Plain text. If you get a File Conversion window, always choose Unicode (UTF-8) and do not mark Insert line breaks nor Allow character substitution.
  7. Upload your final translation file to Amara as instructed above.

Alternatively, you might use more convenient formatting for offline translation using Word.

Using Notepad++

Another option to use for medium geeks who run Windows is the Notepad++ editor. (Real geeks run a flavor of Linux, and can build their own environment even without this help). Notepad++ is an open source, free editor that is offered as a replacement to Windows' built-in Notepad editor. It is much more than a text editor, mostly used for code editing. For translation works its syntax highlighting, and file comparison functions will come very handy.

To install and setup Notepad++

  1. Download and install Notepad++ from http://notepad-plus-plus.org/
  2. If you want to install the spell checker (optional and not available for Hungarian) read the instructions here: http://henrypoon.wordpress.com/2011/03/04/spell-check-on-notepad/
  3. To setup default encoding go to Settings, New Document / Default Directory, Encoding and select UTF-8, than Close.
  4. To setup syntax highlighting for .srt files (this will color the numbers differently, so that timing and subtitle text will look visually different):
    1. Download the SubRip XML file from here http://sourceforge.net/apps/mediawiki/notepad-plus/index.php?title=User_Defined_Language_Files#S (Right click, Save as)
    2. To import the file open View -> User defined dialogue, find the file and click import. Here you can also change how syntax coloring appears.
  5. Now you are all set up for work.

To use Notepad++ for translation:

  1. Download the .srt file from Amara as instructed above.
    Side by side in Notepad++
  2. Make a copy of the downloaded file, with a different name (e.g. change the ENG part to your translating language, like HUN). The original will be your source file that you leave intact, the copy will be your working file.
  3. Open both the source and your work file from Notepad++
  4. Select Plugins -> Compare -> Compare. For better experience in the Compare menu unselect all options except Ignore spacing
  5. This will organize align your two opened files in two parallel windows. Scrolling will be synchronized. When you start Compare, the active, rightmost tab will become the window on the right.
  6. Now you can do your translation by keeping e.g. in the left window the original file, and writing your translation into the other file in the right window.
  7. When you are done, save the result.
  8. Upload your final translation file to Amara as instructed above.


Another method is to use either Gaupol or Subtitle Editor, both of which are to be found in the repositiories of major Linux distributions. Gaupol is also available for Windows.

Using Subtitle Editors

Gaupol

  1. Download the .srt file from Amara as instructed above
    Gaupol
  2. File -> Open
  3. Right-click mouse to the right of where it says "Main Text" and select "Translation Text"
  4. Now you can do your translation, entering it into the column to the right of the column on the left with the downloaded subtitles
  5. File -> Save Translation
  6. Upload your final translation file to Amara as instructed above


Subtitle Editor

  1. Download the .srt file from Amara as instructed above
    Subtitle Editor
  2. File -> Open
  3. View -> Translation
  4. Now you can do your translation, entering it into the column to the right of the column on the left with the downloaded subtitles
  5. File -> Save -> Save Translation
  6. Upload your final translation file to Amara as instructed above


Gnome Subtitles on Linux and Subtitle Workshop on Windows can also be used in a similar way.


A third option is to use a CAT (computer-aided translation) tool.

Using CAT tools

A CAT tool that is particularly suitable for translating .srt files is OmegaT. This software runs on Java, so can be installed on Windows, Mac or Linux.

OmegaT

OmegaT comes with excellent documentation, but basically you need to:
OmegaT
  1. Download the .srt file from Amara as instructed above
  2. Create an empty folder/directory with a name which you would like to give it for the translation work on the .srt, the Project Folder
  3. Start OmegaT
  4. Project -> New
  5. Select the empty folder in the GUI dialogue
  6. In the next GUI which then comes up select your source language (the one of the .srt file you have downloaded) and the one into which you are translating and click OK
  7. In the next GUI you can import your source file, the .srt you downloaded
  8. Omegat should then load your project. It will have created a number of folders in the empty folder you created and place your source .srt file in the one labelled "source"
  9. With the options in the menus you can navigate, adding your translation
  10. Hitting Ctrl+S will save your project and Ctrl+D will create a "target" document. If you do this one after the other after translating each segment, you will not lose your work
  11. When you have finished and hit your final Ctrl+D you should find an .srt in the "target" folder with your translation
  12. Upload your final translation file to Amara as instructed above


OmegaT can connect to the Google Translate and Bing Translator API's.


If you are enamoured with a particular CAT tool and it can accept XLIFF files, then you can convert .srt files to .xlf with Tikal which is part of the Okapi Framework.

Using Google translate

Machine aided translation, such as using e.g. Google translate is a great tool to speed up your translating process. Be aware though, that machines make lots of mistakes during translation, sometimes they even provide misleading interpretations and quite often mess up the grammar. Yet, some simple sentences can be really accurately translated, and they can give you the generic idea and wording what you can use for each line. If you add that to the saved time with typing, you can be about 20% faster with the help of them. (Note: The quality of machine translations varies with languages. Generally Google translate does good job for translation between European languages but doesn’t work well between distant languages like English and Japanese. I don’t recommend the use of machine translation for the latter cases.)

To use Google translate:

  1. Download the original transcript in a .srt file fromat.
  2. Copy the entire content and paste it into the http://translate.google.com window.
  3. Select the source and destination languages and click translate
  4. Copy the translated result and paste it back into your document, overwriting the original text. Save it with a different name.
  5. Important! As part of the translation, Google will change the --> sign that is used for the timing of the subtitles to ->. You must stick to the original .srt format, otherwise you will be unable to upload the result, so you have to change back the -> signs to -->. You can do this easily in one go, in your text editor by using the Replace (or Replace all) function.
  6. Google will also replace the long hyphens to short ones in the text (from -- to -). These, you can change back manually as you do your translation.
  7. Once you have saved the translated raw material, you can either upload it to Amara and continue the manual translation in the Amara interface, or open it in your offline text editor alongside with the original English transcript and do the translation there and then upload the final, corrected result.
  8. In either case, after the final upload and revision, make sure you read and watch your subtitles one last time before you submit it, so that there are no more errors left in it.

Using Subtitle Edit

Subtitle Edit is a freeware PC/Windows application, that also runs on Mono for Mac and Linux users, which makes subtitle translation really easy. See this guide to learn more about using it to work in the OTP.

Personal tools
Namespaces
Variants
Actions
Navigation
Languages
Toolbox